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EXCEL 2000
Use AutoFill to Quickly Copy Formulas and Formatting
Would you like an easy way to extend a series of numbers in Microsoft
Excel without typing each one individually? With AutoFill, you can quickly
copy data, formulas, or formatting to adjacent cells. Follow these steps:
1. Select the cells that you would like to copy.
2. Move the cursor to the bottom right corner of the highlighted cells.
Your cursor will then turn into a black plus sign.
3. Click and hold down the right mouse button and drag across the cells
you want to fill.
4. Release the mouse button, and when the shortcut menu appears, click
Fill Series.
By following these steps, you will be able to save a lot of time creating
your spreadsheets.

Show or Hide the Formulas in an Excel Spreadsheet
When you're working in an Excel worksheet, you can alternate between
viewing the values in the cells and displaying the formulas. To toggle
between the different views, press CTRL+` (single left quotation mark).
Note: If you're having trouble finding the single left quotation
mark, it's on the same key as the "~" symbol. On most keyboards,
it's the key directly to the left of the "1" key.

Don't Lose Sight of Your Column Headings
Would you like to see the column headings on your Microsoft Excel
spreadsheets no matter how far down you scroll? Here is one way to keep
the column headings constantly visible:
1. Select the row just below your column headings.
2. On the Window menu, click Freeze Panes.
The "frozen" column headings don't scroll, but remain visible as you move
through the rest of the worksheet.

Edit Cells Quickly in Excel—Without Using Your Mouse
If you like to use your keyboard for everything, editing a lot of data
quickly in an Excel spreadsheet can be difficult because you find yourself
constantly reaching for the mouse when you want to make changes to a
cell. But there's a shortcut you can use so that your hands never have to
leave the keyboard—press F2. Here's how:
1. Use the arrow keys to select the cell you want to edit.
2. Then press F2 to edit the cell contents.
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3. When you're finished, just press ENTER to enter your changes, or
press ESC to cancel the changes.
Note: This tip is especially handy for editing hyperlinks in Excel
because, if you use your mouse to click on a cell with a hyperlink, it
automatically opens an Internet browser window. Using the
keyboard lets you edit hyperlinks with ease.

Create an Excel Chart with the Push of a Button
This is a very old Microsoft Excel trick. To quickly create a chart, using
only your keyboard, select the data you want to plot and then press F11.
Excel automatically creates the chart for you.
Note: Here is another way to do this trick: After you select your
cells, press ALT+F1 and you'll get the same result.

Select an Entire Range of Cells in Excel
In Excel, if you want to quickly select the entire range of cells you're
working on, press CTRL+SHIFT+ ASTERISK (*).
For example, if you have a list of customers in Excel, this command will
select the entire list and the column headings, but not the empty cells
around the list—so you get only the cells you need. This tip is different
from the Select All command, which selects every cell in the worksheet—
even the ones that you are not using.

Insert Copied Cells between Existing Cells Safely
If you want to insert a range of copied cells between other rows or
columns—instead of pasting over them—there's an easy way to do it:
1. Select the cells you want to copy.
2. On the Edit menu, click Copy.
3. Select the area on the worksheet where you want to place the copied
cells.
4. Press Ctrl + SHIFT + Plus Sign (+).
5. In the Insert dialog box, click the direction you want to shift the
surrounding cells, and press OK.
Now, the copied cells are inserted right where you want them, and none
of your existing information is lost.

Build Vertical Titles in Excel
Have you ever wondered how to create a heading for a table that runs
vertically along the side of a table instead of above it? Here's how to do
it:
1. Select the cell that contains your text as well as the surrounding cells
that you want your title to span.
2. On the Format menu, click Cells, and then click the Alignment tab.
3. In the degrees text box, enter 90.
4. Select the Merge cells text box and click OK.
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Format Excel Cells Fast
If you want quick access to the Format Cells dialog box in Microsoft Excel
to change things like type style, alignments, or borders, select the cell
you want to format and press CTRL+1.

Have Excel Save Your Files Automatically
Have you ever wanted Excel to automatically save your spreadsheets for
you so you don't lose your work? Excel 2000 includes a feature that saves
workbooks automatically at specified intervals, but it's not installed by
default. Here's how you can install and use the AutoSave Add-in:
First you need to load the add-in, which will add it to your Tools menu:
1. On the Tools menu, click Add-Ins.
2. In the Add-Ins available list, select the AutoSave Add-in check
box and then click OK.
Note: If the AutoSave Add-in is not available, you may need to install
it. For more instructions, search for the phrase "Install or remove
individual features of Microsoft Office or Excel" in Excel 2000
Help.
Then, to configure and use the AutoSave feature, follow these steps:
1. On the Tools menu, click AutoSave.
2. Select the Automatic save every check box.
3. In the Minutes box, enter how often you want Excel to save your
workbooks.
4. Select any other options you want, and press OK.

Copy the Contents of an Entire Worksheet
Here's a timesaving tip for Excel users who frequently need to copy an
entire worksheet (a page within a workbook) of information—such as a
list of items for a monthly inventory—from one workbook (Excel file) to
another. To copy an entire sheet to another workbook, follow these steps:
1. Open the workbook into which you want to paste the copied sheet.
2. Switch to the workbook that contains the sheet you want to copy.
3. Right-click the Sheet tab of the sheet you want to copy, and then
click Move or Copy on the shortcut menu.
4. From the To book drop-down menu, select the workbook that will
receive the sheet. (To copy the selected sheet to a new workbook,
click New book on the drop-down menu.)
5. Select the Create a copy check box. (If you don't select this check
box, the sheet will be moved instead of copied.)
6. Click OK.

Do Fast Calculations in Excel
Have you ever needed to know the largest value in a series of cells? You
can create a formula to do that, but there is a faster way. To view the
largest value in a series of cells, do the following:
TIPS & TRICKS

EXCEL 2000, 2002 XP

Page | 9

1. Select the cells in which you are interested, and you will see the sum
of the range displayed on the status bar, which is the horizontal area
below the worksheet window.
2. If the status bar is not displayed, click Status Bar on the View
menu.
3. Right-click the status bar, and then click Max. Now you can see the
maximum value displayed on the status bar.
You can use the same technique to find the average of, the sum of, or the
minimum value in the selected range. You can also count the cells that
contain numbers (by selecting Count Nums) or count the number of
filled cells (by selecting Count).

Quickly Move between Multiple Workbooks/Worksheets
When working with several Excel workbooks or worksheets (the individual
pages in workbooks) at once, you can quickly move between them using
these shortcut keys.
 To move between open workbooks, press CTRL+TAB.
 To move to the next sheet in a workbook, press CTRL+PAGE DOWN.
 To move to the previous sheet in a workbook, press CTRL+PAGE UP.

Completely Delete Cells using this shortcut
Have you ever wanted a keyboard shortcut that completely deletes a cell
from your worksheet, including the formatting and comments? Just select
the cells you want to delete, and then press CTRL+MINUS SIGN (–).
The surrounding cells will shift to fill the space.
This is different from using the DELETE or BACKSPACE keys, which
simply clears the contents of a cell without actually deleting it.

Do Creative Calculations with Paste Special
If you have a block of numeric data in an Excel worksheet and you wish
to change each entry to a negative value, use Paste Special with a twist.
Here's how:
1.
2.
3.
4.
5.
6.

In an empty cell, type -1.
Select the cell, and click Copy on the Edit menu.
Now select the cells containing the values you want to change.
On the Edit menu, click Paste Special.
Under Paste, click Values and under Operation, click Multiply.
Click OK.

All the numbers change from positive to negative, or vice versa. This
method is also useful for reducing numbers by a factor of 1,000,
1,000,000, and so on.

Paste Information from Excel as a Picture
Do you want to place an image of an Excel file into a Word document,
image editing program, or other program? It's easy to do.
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1. On the Excel worksheet or chart sheet, select the cells or click the
chart or object you want to copy.
2. Hold down SHIFT and click Copy Picture on the Edit menu.
3. For best picture quality, make sure As shown on screen and
Picture are selected, and then click OK.
4. Click the worksheet or other document where you want to paste the
picture.
5. Click Paste on the Edit menu.
To make adjustments to the image after you've pasted it, use the Picture
toolbar. (To open it, point to Toolbars on the View menu and click
Picture.)
Note: Cell gridlines appear in the picture if they are displayed. To
omit gridlines, in Excel click Options on the Tools menu, click the
View tab, and then clear the Gridlines check box.

Protect Cells Using Data Validation
Here's a creative way to protect cells in an Excel worksheet so that other
users can't make changes to them:
1. Select the cells you want to protect. (It's a good idea to make a note
of the cells you protect in case you need to remove that protection
later.)
2. On the Data menu, click Validation, and then click the Settings tab.
3. Set the following restrictions: In the Allow box, click Text Length; in
the Data box, click between; in the Minimum box, type 10000; and
in the Maximum box, type 50000.
4. Click the Error Alert tab.
5. Make sure the Show error alert after invalid data is entered
check box is selected. In the Style box, click Stop.
6. If you want a title to appear in the title bar of the message or in the
Office Assistant balloon if the Office Assistant is displayed, type the
text in the Title box. If you leave the Title box blank, the title
defaults to Microsoft Excel.
7. If you want to display your own text for the message, type the text in
the Error message box, up to 225 characters. Press ENTER to start
a new line in the message. If you don't enter any text in the Error
message box, the message displays the following: "The value you
entered is not valid. A user has restricted values that can be entered
into this cell."
Excel displays the message only when a user types data in the cell.
To remove data validation settings, select the protected cells, click
Validation on the Data menu, and then click Clear All.

Quickly View All Worksheet Formulas
With a quick keystroke, you can display all the formulas in your
worksheet, including the serial values Excel uses to store dates.
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To alternate between displaying cell values and displaying cell formulas,
press CTRL+` (single left quotation mark, which usually can be found
above the TAB key).
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EXCEL 2002 XP
Important Note:
You are advised to try TIPS in the Excel 2000 Tips & Tricks section as
well and do not ignore them. They are also safe and tested to work in the
XP version to enhance your output. It does not make a sense; we repeat
all those Excel 2000 Tips in this section.

Counting and Summing Data in Excel
Counting and summing are basic spreadsheet operations and they can go
a long way to helping you get the most out of Microsoft Excel. The
summing and counting formulas should be in the arsenal of every Excel
user. The formulas are based on the worksheet in Figure 1 below.
The 12 data rows in Figure 1 contain
sales
information
for
an
average
company, and consist of three fields: the
sales representative, month of the sale,
and amount of the sale. The examples of
summing and counting formulas will
demonstrate how a small company could
analyze this data. Your data may more
extensive and collected for different
purposes, but the formulas will work just
the same. After explaining the example
formulas, we provide the result of the
formulas based on the data shown in
Figure 1.
Figure 1: Sample Excel worksheet

Summing and Counting
Getting the sum of numbers—be if for your budget, sales statistics, or
inventory—is a common task. Use the SUM function in these instances.
These formulas return the sum of the numbers in the C column:
 Add values within a certain range: =SUM(C2:C13)
o Formula result: 6,125
 Add values for an entire range: =SUM(C:C). New data is often
added to an existing table, so the number of rows will vary. This
formula adds up the entire column and eliminates the need to edit
your formula when new data is inserted.
For counting values, use the COUNT function. It returns the number of
values in a range and can quickly determine how many cells contain
numeric information. This can be helpful, for example, when trying to
determine how many months had sales.
 Count values in a range: =COUNT(C2:C13)
o Formula result: 12
TIPS & TRICKS

EXCEL 2000, 2002 XP

P a g e | 13

 Count values in the entire range: =COUNT(C:C)
Although column C contains 13 entries, these formulas return 12 because
the COUNT function only counts numeric values. If you need to count all
the cells in a range that contain any information, use the COUNTA
function, such as: =COUNTA(A:A). This formula will return a result of 13.

Conditional Counting & Summing Using Single Condition
In many cases, you don't want to count or sum all of the records. Rather,
you want to focus on records that meet a certain condition, for example,
only the sales made by a sales representative. Use the COUNTIF and
SUMIF functions to return these types of results.

Count the Number of Sales by a Sales Representative
The following formula is a straightforward use of the COUNTIF function. It
counts the sales made by Jones:
 =COUNTIF(A2:A13,"Jones")
 Formula result: 4
You can also write this formula as: =COUNTIF(A2:A13,"=Jones"). If a
comparison operator is omitted, Excel assumes "equal to."

Count the Number of Sales Made by Other Sales Reps
This formula counts all the sales not made by Jones:
 =COUNTIF(A2:A13,"<>Jones")
 Formula result: 8

Count the Number of Sales Greater than a Target Value
This formula counts the number of sales in C2:C13 that are greater than a
target value. In this example, the target value would have to be entered
into D1. This COUNTIF function accepts a cell reference in the second
argument. Also, notice that this formula uses the concatenation operator
(&) to join the greater than symbol (>) with the cell reference.
 =COUNTIF(C2:C13,">"&D1)

Count the Number of Sales Greater than the Sales
Average
This formula returns the number of sales that exceed the average sales
amount. This formula also shows that you can use a function as the
second argument for COUNTIF:
 =COUNTIF(C2:C13,">"&AVERAGE(C2:C13))
 Formula result: 5

Conditional Summing
The SUMIF function is similar to COUNTIF, but it uses an additional
argument. The first argument refers to the range that is being evaluated,
the second argument represents the criteria, and the third argument is
the range to be summed.
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Add Up Sales in a Given Month
This formula adds up all the sales in January:
 =SUMIF(B2:B13,"=Jan",C2:C13)
 Formula result: 1,925
As with the COUNTIF function, an "equal to" condition is assumed if the
comparison operator is omitted. The preceding formula could have been
written as: =SUMIF(B2:B13,"=Jan",C2:C13).

Add Up Sales Made by Other Sales Representatives
This formula adds up the sales made by sales representatives other than
Rogers. It uses a "not equal to" comparison:
 =SUMIF(A2:A13,"<>Rogers",C2:C13)
 Formula result: 4,425

Add Up the Sales Greater than a Certain Value
This formula adds up all the values that are greater than 500. In this
formula, the condition being evaluated is based on the same range that is
being summed:
 =SUMIF(C2:C13,">500",C2:C13)
 Formula result: 4,450
Note: The COUNTIF and SUMIF functions can also use wildcard
comparison characters. For more information, in Excel Help
search for "wildcard."

Conditional Counting and Summing
The formulas in the section return counts or sums based on two or more
conditions (Multiple Conditions).

Count the Number of Months a Sales Rep. Made a Sale
This formula counts the number of times Jones made sales in February. It
is a conditional counting formula that uses two conditions.
 =SUMPRODUCT((A2:A13="Jones")*(B2:B13="Feb"))
 Formula result: 2
Table 1 shows what's going on behind the scenes. The first column shows
the result of the first part of the argument. The second column shows the
result of the second part of the argument. The last column shows the
result of multiplying the first two columns. When both columns are TRUE,
the result of multiplying similar values is 1. The formula then returns the
sum of these multiplications.

Count Months When Sales Greater than a Amount
You can use a formula similar to the one above to work with numeric
data. This formula returns the number of rows in which the month is
January and the amount is greater than 200.
 =SUMPRODUCT((B2:B13="Jan")*(C2:C13>200))
 Formula result: 4
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Count the Number of Sales between Specific Values
This formula counts the number of times the sales amount falls between
two 200 and 500. The formula uses two conditions: the amount greater
than or equal to 200, and the amount less than or equal to 500.
 =SUMPRODUCT((C2:C13>=200)*(C2:C13<=500))
 Formula result: 5

Count the Number of Sales Based on Three Conditions
This formula returns the amount when the sales representative is Jones,
the month is February, and the amount is greater than 500. This function
uses a single argument, which consists of three logical expressions
multiplied together. The result is the sum of these products.
 =SUMPRODUCT((A2:A13="Jones")*(B2:B13="Feb")*(C2:C13>500
))
 Formula result: 1

Add Up a Representative’s Sales in One Month
The formula below adds up sales amount based on two conditions: when
the sales representative is Jones and the month is February.
 =SUMPRODUCT((A2:A13="Jones")*(B2:B13="Feb")*(C2:C13))
 Formula result: 1,150

Add the Combined Sales for Two Sales Representatives
The formula below returns the sum of the sales amount for both Jones
and Rogers. This formula uses a single argument and consists of three
expressions. Notice, however, that the first two arguments are not
multiplied as in the previous examples. Because we are doing a logical OR
comparison, they are summed. Summing two logical values results in a
value of 1 when either of the expressions is TRUE.
 =SUMPRODUCT(((A2:A13="Jones")+(A2:A13="Rogers"))*(C2:C13
))
 Formula result: 3,175

Stop Avoiding Using Formulas in Excel
Microsoft Excel formulas aren't what you think they are. They're not
complicated bundles of keystrokes and symbols designed to boost the
egos of only accountants or tax attorneys. In fact, sometimes a formula
has nothing to do with numbers at all.
Simply speaking, formulas are equations that perform calculations on
values in your worksheet. These values can be numbers, dates, text, or
anything else you can type into a cell. Here are a couple of useful things
you can do with formulas:






Convert times (such as from standard time format to decimal format)
Calculate a running balance
Calculate the difference between two numbers as a percentage
Remove spaces from the beginning and end of a cell
Count unique entries in a list
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Take a little time to learn about Excel formulas. Once you get the hang of
it, using them, can really save you time and enable you to do complicated
things you never thought possible.

About formulas
Formulas are equations that perform calculations on values in your
worksheet. A formula starts with an equal sign (=). For example, the
following formula multiplies 2 by 3 and then add 5 to the result.
=5+2*3
A formula can also contain any or all of the following:
-

functions,
references,
operators, and
constants.

Parts of a formula
1. Functions: The PI() function returns the value of pi: 3.142...
2. References (or names): A2 returns the value in cell A2.
3. Constants: Numbers or text values entered directly into a
formula, such as 2.
4. Operators: The ^ (caret) operator raises a number to a power, and
the * (asterisk) operator multiplies.

About functions in formulas
Functions are predefined formulas that perform calculations by using
specific values, called arguments, in a particular order, or structure.
Functions can be used to perform simple or complex calculations. For
example, the ROUND function rounds off a number in cell A10.

Structure of a function
1. Structure.
The structure of a function begins with an equal sign (=), followed
by the function name, an opening parenthesis, the arguments for
the function separated by commas, and a closing parenthesis.
2. Function name.
For a list of available functions, click a cell and press SHIFT+F3.
3. Arguments.
Arguments can be numbers, text, logical values such as TRUE or
FALSE, arrays, error values such as #N/A, or cell references. The
argument you designate must produce a valid value for that
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argument. Arguments can also be constants, formulas, or other
functions.
4. Argument tooltip.
A tooltip with the syntax and arguments appears as you type the
function. For example, type =ROUND (and the tooltip appears.)
Tooltips only appear for built-in functions.
5. Entering formulas
When you create a formula that contains a function, the Insert
Function dialog box helps you enter worksheet functions. As you
enter a function into the formula, the Insert Function dialog box
displays the name of the function, each of its arguments, a
description of the function and each argument, the current result of
the function, and the current result of the entire formula.

Nested functions
In certain cases, you may need to use a function as one of the arguments
of another function. For example, the following formula uses a nested
AVERAGE function and compares the result with the value 50.

Valid returns
When a nested function is used as an argument, it must return the same
type of value that the argument uses. For example, if the argument
returns a TRUE or FALSE value, then the nested function must return a
TRUE or FALSE. If it doesn't, Microsoft Excel displays a #VALUE! error
value.

Nesting level limits
A formula can contain up to seven levels of nested functions. When
Function B is used as an argument in Function A, Function B is a secondlevel function. For instance, the AVERAGE function and the SUM function
are both second-level functions because they are arguments of the IF
function. A function nested within the AVERAGE function would be a
third-level function, and so on.

About References in Formulas
A reference identifies a cell or a range of cells on a worksheet and tells
Microsoft Excel where to look for the values or data you want to use in a
formula. With references, you can use data contained in different parts of
a worksheet in one formula or use the value from one cell in several
formulas. You can also refer to cells on other sheets in the same
workbook, and to other workbooks. References to cells in other
workbooks are called links.

The A1 Reference Style
By default, Excel uses the A1 reference style, which refers to columns
with letters (A through IV, for a total of 256 columns) and refers to rows
with numbers (1 through 65536). These letters and numbers are called
row and column headings. To refer to a cell, enter the column letter
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followed by the row number. For example, B2 refers to the cell at the
intersection of column B and row 2.
To refer to

Use

The cell in column A and row 10

A10

The range of cells in column A and rows 10 through 20

A10:A20

The range of cells in row 15 and columns B through E

B15:E15

All cells in row 5

5:5

All cells in rows 5 through 10

5:10

All cells in column H

H:H

All cells in columns H through J

H:J

The range of cells in columns A through E
and rows 10 through 20

A10:E20

Reference to another worksheet
In the following example, the AVERAGE worksheet function calculates the
average value for the range B1:B10 on the worksheet named Marketing in
the same workbook.

Link to another worksheet in the same workbook
Note that the name of the worksheet and an exclamation point (!)
precede the range reference.

The difference between relative and absolute references
Relative references
A relative cell reference in a formula, such as A1, is based on the relative
position of the cell that contains the formula and the cell the reference
refers to. If the position of the cell that contains the formula changes, the
reference is changed.
If you copy the formula across rows or down columns, the reference
automatically adjusts. By default, new formulas use relative references.
For example, if you copy a relative reference in cell B2 to cell B3, it
automatically adjusts from =A1 to =A2.
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Copied formula with relative reference
Absolute references
An absolute cell reference in a formula, such as $A$1, always refer to a
cell in a specific location. If the position of the cell that contains the
formula changes, the absolute reference remains the same. If you copy
the formula across rows or down columns, the absolute reference does
not adjust. By default, new formulas use relative references, and you
need to switch them to absolute references. For example, if you copy a
absolute reference in cell B2 to cell B3, it stays the same in both cells
=$A$1.

Copied formula with absolute reference
Mixed references
A mixed reference has either an absolute column and relative row, or
absolute row and relative column. An absolute column reference takes the
form $A1, $B1, and so on. An absolute row reference takes the form A$1,
B$1, and so on. If the position of the cell that contains the formula
changes, the relative reference is changed, and the absolute reference
does not change. If you copy the formula across rows or down columns,
the relative reference automatically adjusts, and the absolute reference
does not adjust. For example, if you copy a mixed reference from cell A2
to B3, it adjusts from =A$1 to =B$1.

Copied formula with mixed reference
The 3-D Reference Style
If you want to analyze data in the same cell or range of cells on multiple
worksheets within the workbook, use a 3-D reference. A 3-D reference
includes the cell or range reference, preceded by a range of worksheet
names. Excel uses any worksheets stored between the starting and
ending names of the reference. For example, =SUM(Sheet2:Sheet13!B5)
adds all the values contained in cell B5 on all the worksheets between and
including Sheet 2 and Sheet 13.
 You can use 3-D references to refer to cells on other sheets, to
define names, and to create formulas by using the following
functions: SUM, AVERAGE, AVERAGEA, COUNT, COUNTA, MAX,
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MAXA, MIN, MINA, PRODUCT, STDEV, STDEVA, STDEVP,
STDEVPA, VAR, VARA, VARP, and VARPA.
 3-D references cannot be used in array formulas.
 3-D references cannot be used with the intersection operator (a
single space) or in formulas that use implicit intersection.

The 3-D References
The 3-D references change when you move, copy, insert, or delete
worksheets. The following examples explain what happens when you
move, copy, insert, or delete worksheets that are included in a 3-D
reference. The examples use the formula =SUM(Sheet2:Sheet6!A2:A5) to
add cells A2 through A5 on worksheets 2 through 6.

Insert or copy
If you insert or copy sheets between Sheet2 and Sheet6 (the endpoints in
this example), Microsoft Excel includes all values in cells A2 through A5
from the added sheets in the calculations.

Delete
If you delete sheets between Sheet2 and Sheet6, Excel removes their
values from the calculation.

Move
If you move sheets from between Sheet2 and Sheet6 to a location outside
the referenced sheet range, Excel removes their values from the
calculation.

Move an endpoint
If you move Sheet2 or Sheet6 to another location in the same workbook,
Excel adjusts the calculation to accommodate the new range of sheets
between them.

Delete an endpoint
If you delete Sheet2 or Sheet6, Excel adjusts the calculation to
accommodate the range of sheets between them.

The R1C1 Reference Style
You can also use a reference style where both the rows and the columns
on the worksheet are numbered. The R1C1 reference style is useful for
computing row and column positions in macros. In the R1C1 style, Excel
indicates the location of a cell with an "R" followed by a row number and a
"C" followed by a column number.
Reference

Meaning

R[-2]C

A relative reference to the cell two rows up and in the
same column

R[2]C[2]

A relative reference to the cell two rows down and two
columns to the right
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R2C2

An absolute reference to the cell in the second row and in
the second column

R[-1]

A relative reference to the entire row above the active cell

R

An absolute reference to the current row

When you record a macro, Excel records some commands by using the
R1C1 reference style. For example, if you record a command such as
clicking the AutoSum button to insert a formula that adds a range of
cells, Excel records the formula by using R1C1 style, not A1 style,
references.

To turn R1C1 reference style on or off
1. Click Options on the Tools menu, and then click the General tab.
2. Under Settings, select or clear the R1C1 reference style check box.

About Names in Formulas
You can use the labels of columns and rows on a worksheet to refer to the
cells within those columns and rows. Or you can create descriptive names
to represent cells, ranges of cells, formulas, or constant values. Labels
can be used in formulas that refer to data on the same worksheet; if you
want to represent a range on another worksheet, use a name.

Using names to represent cells, constants, or formulas
A defined name in a formula can make it easier to understand the
purpose of the formula. For example, the formula
=SUM(FirstQuarterSales) might be easier to identify than
=SUM(C20:C30).
Names are available to any sheet. For example, if the name
ProjectedSales refers to the range A20:A30 on the first worksheet in a
workbook, you can use the name ProjectedSales on any other sheet in the
same workbook to refer to range A20:A30 on the first worksheet.
Names can also be used to represent formulas or values that do not
change (constants). For example, you can use the name SalesTax to
represent the sales tax amount (such as 6.2 percent) applied to sales
transactions.
You can also link to a defined name in another workbook, or define a
name that refers to cells in another workbook. For example, the formula
=SUM(Sales.xls!ProjectedSales) refers to the named range ProjectedSales
in the workbook named Sales.

Guidelines for Names
What characters are allowed?
The first character of a name must be a letter or an underscore character.
Remaining characters in the name can be letters, numbers, periods, and
underscore characters.
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Can names be cell references?
Names cannot be the same as a cell reference, such as Z$100 or R1C1.

Can more than one word be used?
Yes, but spaces are not allowed. Underscore characters and periods may
be used as word separators — for example, Sales_Tax or First.Quarter.

How many characters can be used?
A name can contain up to 255 characters.
Note: If a name defined for a range contains more than 253
characters, you cannot select it from the Name box.

Are names case sensitive?
Names can contain uppercase and lowercase letters. Microsoft Excel does
not distinguish between uppercase and lowercase characters in names.
For example, if you have created the name Sales and then create another
name called SALES in the same workbook, the second name will replace
the first one.

Using Existing Row and Column Labels as Names
When you create a formula that refers to data in a worksheet, you can
use the column and row labels in the worksheet to refer to the data. For
example, to calculate the total value for the Product column, use the
formula =SUM(Product).

Using a Label
Or if you need to refer to the Product 3 amount for the East division (that
is, the value 110.00), you can use the formula =Product 3 East. The
space in the formula between "Product 3" and "East" is the intersection
operator. This operator designates that Microsoft Excel should find and
return the value in the cell at the intersection of the row labeled East and
the column labeled Product 3.
Note: By default, Excel does not recognize labels in formulas. To
use labels in formulas, click Options on the Tools menu, and then
click the Calculation tab.
Under Workbook options, check the Accept labels in formulas box.

Stacked Labels
When you use labels for the columns and rows on your worksheet, you
can use those labels to create formulas that refer to data on the
worksheet. If your worksheet contains stacked column labels — in which a
label in one cell is followed by one or more labels below it — you can use
the stacked labels in formulas to refer to data on the worksheet. For
example, if the label West is in cell E5 and the label Projected is in cell E6,
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the formula =SUM(West Projected) returns the total value for the West
Projected column.

The Order for Stacked Labels
When you refer to information by using stacked labels, you refer to the
information in the order in which the labels appear, from top to bottom. If
the label West is in cell F5 and the label Actual is in cell F6, you can refer
to the actual figures for West by using West Actual in a formula. For
example, to calculate the average of the actual figures for West, use the
formula =AVERAGE(West Actual).

Using Dates as Labels
When you label a range by using the Label Ranges dialog box and the
range contains a year or date as a label, Excel defines the date as a label
by placing single quotation marks around the label when you type the
label in a formula. For example, suppose your worksheet contains the
labels 2007 and 2008 and you have specified these labels by using the
Label Ranges dialog box. When you type the formula =SUM(2008),
Excel automatically updates the formula to =SUM('2008').

About Calculation Operators in Formulas
Operators specify the type of calculation that you want to perform on the
elements of a formula. Microsoft Excel includes four different types of
calculation operators: arithmetic, comparison, text, and reference.

Types of Operators
Arithmetic operators
To perform basic mathematical operations such as addition, subtraction,
or multiplication; combine numbers; and produce numeric results, use the
following arithmetic operators.
Arithmetic operator Meaning (Example)
+ (plus sign)

Addition (3+3)

– (minus sign)

Subtraction (3–1)
Negation (–1)

* (asterisk)

Multiplication (3*3)

/ (forward slash)

Division (3/3)

% (percent sign)

Percent (20%)

^ (caret)

Exponentiation (3^2)

Comparison operators
You can compare two values with the following operators. When two
values are compared by using these operators, the result is a logical value
either TRUE or FALSE.
Comparison operator

Meaning (Example)

= (equal sign)

Equal to (A1=B1)
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> (greater than sign)

Greater than (A1>B1)

< (less than sign)

Less than (A1<B1)

>= (greater than or equal to sign) Greater than or equal to (A1>=B1)
<= (less than or equal to sign)

Less than or equal to (A1<=B1)

<> (not equal to sign)

Not equal to (A1<>B1)

Text concatenation operator
Use the ampersand (&) to join, or concatenate, one or more text strings
to produce a single piece of text.
Text operator

Meaning (Example)

& (ampersand)

Connects, or concatenates, two values to produce one
continuous text value ("North"&"wind")

Reference operators
Combine ranges of cells for calculations with the following operators.
Reference
operator

Meaning (Example)

: (colon)

Range operator, which produces one reference to all
the cells between two references, including the two
references (B5:B15)

, (comma)

Union operator, which combines multiple references
into one reference (SUM(B5:B15,D5:D15))

(space)

Intersection operator, which produces on reference to
cells common to the two references (B7:D7 C6:C8)

The Order, Excel Performs Operations in Formulas
Formulas calculate values in a specific order. A formula in Excel always
begins with an equal sign (=). The equal sign tells Excel that the
succeeding characters constitute a formula. Following the equal sign are
the elements to be calculated (the operands), which are separated by
calculation operators. Excel calculates the formula from left to right,
according to a specific order for each operator in the formula.

Operator precedence
If you combine several operators in a single formula, Excel performs the
operations in the order shown in the following table. If a formula contains
operators with the same precedence — for example, if a formula contains
both a multiplication and division operator — Excel evaluates the
operators from left to right.
Operator

Description

: (colon)
, (comma)
(single space)

Reference operators
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–

Negation (as in –1)

%

Percent

^

Exponentiation

* and /

Multiplication and division

+ and –

Addition and subtraction

&

Connects two strings of text (concatenation)

= < > <= >= <> Comparison

Use of parentheses
To change the order of evaluation, enclose in parentheses the part of the
formula to be calculated first. For example, the following formula
produces 11 because Excel calculates multiplication before addition. The
formula multiplies 2 by 3 and then adds 5 to the result.
=5+2*3
In contrast, if you use parentheses to change the syntax, Excel adds 5
and 2 together and then multiplies the result by 3 to produce 21.
=(5+2)*3
In the example below, the parentheses around the first part of the
formula force Excel to calculate B4+25 first and then divide the result by
the sum of the values in cells D5, E5, and F5.
=(B4+25)/SUM(D5:F5)

About constants in formulas
A constant is a value that is not calculated. For example, the date
10/9/2008, the number 210, and the text "Quarterly Earnings" are all
constants. An expression, or a value resulting from an expression, is not a
constant. If you use constant values in the formula instead of references
to the cells (for example, =30+70+110), the result changes only if you
modify the formula yourself.

Building Formulas Faster in Excel 2002
Microsoft Excel 2002 provides more tools to help you build formulas that
use functions faster and more easily than ever before. Don't just AutoSum
— AutoAverage, AutoCount, and more!
Previous versions of Excel included the AutoSum button, which allowed
you to calculate the sum of a range of cells with the click of a button.
Now, clicking the same button also gives you the opportunity to
automatically average, count, or get the maximum or minimum value in a
range. Just select a range of values, then click the arrow on the
AutoSum button, and click the operation you want -- Sum, Average,
Count, Max or Min.
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ScreenTips will help!
Enter function arguments with ease
Now, when you start typing a formula that includes a function, Excel
provides on the spot help by displaying a screen tip that shows the
arguments necessary for the function. Each time you enter an argument,
the next argument in the function is highlighted for you. Additionally, if
you click on the function name in the ScreenTip, a Help topic with more
information and examples for using that function is displayed.

Let Excel show you where the errors are
Like a spelling checker, Excel 2002 provides an error checker. You can
start it manually by clicking Error checking on the Tools menu. It will
check formulas for error values, for numbers stored as text, for formulas
referring to empty cells, and more.
When background error checking is enabled (as it is by default), you don't
even have to start the error checker manually. Excel indicates a formula
that doesn't follow prescribed standards by placing green triangles in cells
with possible errors. If you select the cell, the Error Checking Options
smart tag is displayed, and you can click the arrow on it to get more
information or see a list of options such as Help on this error, Show
Calculation Steps, and Ignore Error.

Excel also contains a formula auditing toolbar that, among other options,
lets you graphically trace precedent cells (cells with formulas that refer to
the cell you're auditing) and dependent cells (cells that the cell you're
auditing refer to). In the following illustration, blue indicators point to
precedent or dependent cells.
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Suggest a new function
Type a natural language question in the Insert Function dialog box, and
Excel lists possible functions to suit your needs. For example, type "how
do I calculate monthly payments on a loan," and Excel suggests using the
PMT function (which calculates the payment for a loan) or the NPER
function (which returns the number of periods for an investment).

Cut and Paste Function Examples from Help
Look up a function, and check out the example at the bottom of the Help
pane. You can even cut and paste the example, which includes formulas
and data directly from Help onto your worksheet and watch it calculate to
get a better idea of how the function works. The following illustration
shows what such an example looks like.

See results in cells without scrolling
The Watch Window is an individual window that allows you to see
what's going on in cells without having to scroll to the cells themselves.
For example, let's say you're entering data on row 162 that may affect
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the result of a formula in cell A10. Rather than scrolling back to A10 to
see the result of the formula, you can "watch" the value of the formula
change from within the window, no matter where you are on the
worksheet. You can even watch values on other sheets or in other
workbooks. Additionally, you can click the cell reference in the Watch
Window to move the selection to the cell you're watching. To watch a
cell, just right-click the cell and click Add Watch.

Evaluate formulas one expression at a time
Even when a formula appears to be entered correctly, the order of the
functions or operations may not be correct in order to get the results you
want. The Evaluate Formula feature is handy for calculating the different
parts of a formula especially nested formula in the order that the formula
evaluates them so that you can zero in on the specific part of the formula
that may not be working the way you expect.
Evaluating a formula is something like using a debugging tool in a
programming environment. It allows you to step in or step out of each
section in the formula, and evaluate the section you want.
So, for example, let's say you have the following formula in cell D5:
=IF(AVERAGE(B2:B5)<50,SUM(C2:C5),0)
This formula says that if the average of the values in cells B2 through B5
is less than 50, then sum the values in the cells C2 through C5;
otherwise, return 0.
You can use Evaluate Formula to see the formula evaluated one
expression at a time. For example, when you first open the Evaluate
Formula dialog box, you see the formula with the first expression
underlined like this:
=IF(AVERAGE(B2:B5)<50,SUM(C2:C5),0)
When you click Evaluate, the underlined expression is evaluated and the
result shown like this (assuming that the values in B2:B5 are 51, 49,39,
and 68):
=IF(51.75<50,SUM(C2:C5),0)
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Click Evaluate again and see that because 51.75 is more than 50, that
expression evaluates to FALSE:
=IF(FALSE,SUM(C2:C5),0)
and since the expression evaluates to FALSE, the entire expression
evaluates to zero.
To evaluate a formula, point to Formula Auditing on the Tools menu,
and then click Evaluate Formula.
Note: An option called Show Calculation Steps is available on
the Error Checking Options smart tag menu. This option is similar
to Evaluate Formula, except that the first expression is already
evaluated when the dialog box is displayed.

Count the number of words in a cell
You can count the number of words in a cell by using the following
formula:
=IF(LEN(TRIM(A1))=0,0,LEN(TRIM(A1))-LEN(SUBSTITUTE(A1," ",""))+1)
In this example, imagine that cell A1 contains the text "Have a nice day!",
and cell A2 contains the formula. The formula returns a value of 4 to
reflect that the cell contains four words separated by spaces. It makes no
difference if words are separated by multiple spaces or if words start or
end with a space. The TRIM function removes extra spaces, starting
spaces, and ending spaces in the text of the cell.

Count the number of words in a worksheet
The easiest way to count the number of words in a worksheet is to export
the worksheet to Microsoft Word and use the Word Count feature. For
more information about how to use this feature, see Word Help.

Perform Quick Operations on Your Excel Data
Have you ever wanted to quickly perform an operation on your Excel
data, without replacing the data? For example, maybe you have some
yearly figures, and you want to see what the daily ones look like. It's easy
to do, using the Paste Special command.
1.
2.
3.
4.
5.

Type =365 in a cell.
Click Copy.
Highlight the data for which you want the daily figures.
On the Edit menu, click Paste Special.
In the Paste Special dialog box, click Divide and then click OK.

All of the data you have highlighted will be divided by 365. If you click in
any of the cells, you'll see the operation that was performed displayed in
the formula bar.
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Keep Links to Source Workbooks Up-to-Date
One of the great things about Excel is that you can create formulas in one
workbook that link to data stored in another (source) workbook. But,
when your source workbook changes regularly (for example, if you update
the source and save it under a new name each month), it can be very
time-consuming to find and update links to the old source workbook.
Fortunately, there's an easy way to do this:
1. Open the workbook that contains the link(s).
2. On the Edit menu, click Links.
3. In the Source box, click the name of the link with the source you
would like to change.
4. Click Change Source.
5. In the Change Source dialog box, click the source workbook you
want to refer to.
Note: To successfully change source workbooks, the linked data must
reside in the same cells (for example, A15, D24) in the new source
workbook as they did in the old.

Links that are not in the Edit Links Dialog Box
Microsoft Excel makes it easy to manage links within a workbook and to
check on the status of those links. Just click Links on the Edit menu to
display the Edit Links dialog box. Note, however, that the following types
of links will not be listed:
 Links in Web queries containing parameters
 Links in defined names that are not used in a formula

Use a Shortcut to Insert Time/Date in Excel
Here are a few keyboard shortcuts you can use to insert the current time
and date in a Microsoft Access table or Excel spreadsheet.
 Current date: Press CTRL+SEMICOLON
 Current time: Press CTRL+SHIFT+ SEMICOLON
 Current date and time: Press CTRL+ SEMICOLON then SPACE
then CTRL+SHIFT+ SEMICOLON
Note: When you insert the date and time using this tip, the
information
remains
static.
To
update
this
information
automatically, you must use the TODAY and NOW functions. To
learn how to do this, search for Insert the current date and time
in a cell in Excel Help and then click Insert a date or time whose
value is updated.

Use your Spreadsheet like a Database with AutoFilter
You can use AutoFilter to analyze the data in your Microsoft Excel
spreadsheet based on specific criteria. For example, if you are a
salesperson who has a spreadsheet listing all the clients you have in each
region you cover, you can use AutoFilter to sort by a specific region and
get a snapshot of just the clients in that region. Here's how:
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1. Click a cell in the list you want to filter. You should choose a cell
that appears in a row that contains a heading and related data,
such as a set of client names or phone numbers.
2. On the Data menu, point to Filter, and then click AutoFilter.
Arrows appear at the heading of each column.
3. Click an arrow, and choose your filter criteria from the drop-down
menu. (For example, you could filter for a number that's greater or
less than a target figure.)
Only rows containing data that meet the criteria are displayed. Great for
reporting!

Enter more than One Line in an Excel Cell
There are two ways you can display multiple lines of data in a Microsoft
Excel 2002 cell.

To enter a line break
 Press ALT+ENTER to start a new line while you're typing or editing
data.

To wrap text automatically
1. Click the cell you want.
2. On the Format menu, click Cells and then the Alignment tab.
3. Select the Wrap text check box.
Data in the cell will wrap to fit the column width. You can make the
column wider or narrower to adjust the width of the data.

Navigate Blocks of Data in Excel
A simple way to navigate through blocks of neighboring data in Excel
version 2002 is to use the END key in combination with the arrow keys.
To move by one block of data within a row or column, press END followed
by an arrow key. For example, to move to the last (or rightmost) cell in a
row of data, press END+RIGHT ARROW. Or, to move to the last cell in
the worksheet, in the bottom-most used cell of the rightmost used
column, press CTRL+END.

Draw Borders in Excel Worksheets
For years Microsoft Word users have been able to create tables that meet
their own unique specifications. Now, Excel version 2002 offers users a
similar feature: Draw Borders. Here's how to use it:
1. On the Formatting toolbar, click the arrow next to Borders, and
then click Draw Borders on the palette.
2. On the Borders toolbar, click the arrow next to Draw Border or
Draw Border Grid, and then click Draw Border on the palette.
3. Do one or more of the following:
a. Draw a border line on cells. Click the line you want as a border
or click and drag on the lines you want as borders.
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b. Draw an outside border around a row. Click in the center of a
cell and drag across the row.
c. Draw an outside border around a column. Click in the center
of a cell and drag down the column.
4. When you are finished drawing borders, close the Borders toolbar to
leave Draw Borders mode.
There are some keyboard shortcuts to use with the new Draw Borders
feature. Here are they:
 To draw borders around every cell within the row or column, press
the CTRL key while you drag the cursor.
 To erase the borders you've drawn around a row or column, press
the SHIFT key while you drag the cursor across the row or down the
column.
 To erase the borders you've drawn around every cell within a row or
column, press CTRL+SHIFT while you drag the cursor across the
row or down the column.
Note: To apply a different line style to a border, click the arrow
next to Line Style, and then click a line style on the palette. To
apply a different line color to a border, click Line Color, and then
click a color on the palette.

Hide Whole Worksheets in Excel
You can hide Excel worksheets to reduce the number of sheets on the
screen and to prevent unwanted changes. When you hide parts of a
workbook, the data disappears from view but is not deleted from the
workbook.
1. Select the sheets you want to hide.
2. On the Format menu, point to Sheet, and then click Hide.
Note: You will not be able to hide a worksheet if the workbook has
been protected.

Get Easy Access to New AutoSum Functions
In older versions of Excel, the AutoSum feature was handy, but limited. In
Excel 2002, the AutoSum button is linked to a longer list of formulas that
you can add to your worksheet. With this more powerful AutoSum, you
can quickly calculate the average of selected cells, find the maximum or
minimum value in a range of values, and much more.
1. Click the cell below the column of numbers, or to the right of the
row of numbers, you want to calculate.
2. Click the arrow next to AutoSum on the Standard toolbar, click
the formula you want to use, and then press ENTER.

Switch Rows to Columns or Columns to Rows
Maybe you have a column of text that you want to move into a row, so
that you can use the text as column labels in a table. Or maybe you have
a row of data that you want to move into a table in which the data is
TIPS & TRICKS

EXCEL 2000, 2002 XP

P a g e | 33

organized in columns. You know it would be tedious to move the data
manually, one item at a time. But you may not know that you can use the
Paste button to quickly transpose a column of data to a row of data, or
vice versa.

To switch a row of data to a column, or vice versa
1. Select the cells that you want to switch.
2. On the Edit menu, click Copy.
3. Select the upper-left cell of the area where you want to paste the
data. The paste area must be outside the copy area.
4. Click the arrow to the right of the Paste button, and then click
Transpose.
Data from the top row of the copy area appears in the left column of the
paste area, and data from the left column appears in the top row.

Switch between Absolute and Relative Cell References
When you create a formula in Excel, the formula can use relative cell
references, which refer to cells relative to the position of the formula, or
absolute references, which refer to cells in a specific location. Formulas
can also contain a mix of relative and absolute references. An absolute
reference is indicated by the $ symbol. For example, $B$1, is an absolute
reference to column B, row 1.
When working with formulas, you can easily change column and row
references from relative to absolute, and back again by using this handy
shortcut:
1. Select the cell that contains the formula.
2. In the formula bar, select the reference you want to change.
3. Press F4 to toggle through the combinations.

Color-Code Your Excel Sheet Tabs
In Excel 2002, you can color-code sheet tabs for easier identification or
grouping of related sheets. Here's how:
1. Select the sheets you want to color by holding down the CTRL key
and clicking the tabs.
2. On the Format menu, point to Sheet, and then click Tab Color. You
can also right-click the sheet tab and then click Tab Color.
3. Click the color you want, and click OK.

Quickly Calculate a Person's Age in Excel
The DATEDIF() function in Excel calculates the number of days, months,
or years between two dates. So, this function makes it easy to calculate a
person's age. To try this tip, follow these steps:
1. In a blank worksheet, type the birth date in cell A1, using slashes to
separate day, month, and year.
2. In cell A2, type =DATEDIF(A1,TODAY(),"y") and press ENTER.
The age (in years) will be displayed in cell A2.
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Note: For more information on the proper syntax to use for the IF
worksheet function, search for IF worksheet function in Excel
Help.

Quickly sum cell values without modifying a worksheet
There is no need to type formulas in spreadsheet cells unless you need to.
Fortunately, there is a quick way to display summary formulas in the
Excel status bar (the thin bar between an Excel workbook and the Start
menu):
1. Start Excel. A new, blank workbook appears.
2. In cells A1 through A10, type a number in each cell.
3. If the status bar is not visible, on the Tools menu, click Options.
Then, on the View tab, select the Status bar check box.
4. Select cells A1 through A10, inclusive.
5. Right-click anywhere in the status bar, and click Sum in the list that
appears.
The sum of cells A1 through A10 appears in the status bar to the right,
and the layout of the original worksheet is not modified.

Quickly Clear All Spreadsheet Formatting
Here's an easy way to quickly clear all formatting in your Excel
spreadsheet.
1. Click any cell in the spreadsheet and then press CTRL+A to select all
cells in the worksheet.
2. On the Edit menu, point to Clear, and then click Formats.

Print a Selection of Cells in an Excel Worksheet
If you are working with large amounts of data, you might want to print
only a range of information — for example, to share with peers at a
meeting. You can select specific cells in two ways. The first way gives you
the most control while you select. The second allows you to select cells
quickly and to select multiple cells across a worksheet and all cells
containing data in the columns you select. To print a selection of cells do
the following:1. Click the first cell in the range you want to print.
2. Do one of the following:
 To select cells of data one at a time, press the SHIFT key and
then use the arrow keys to select the cells you want.
 Select a range of adjacent cells, press SHIFT+CTRL and then
use the arrow keys to select the cells you want. To select
nonadjacent cells or cell ranges, select the first cell or range of
cells, and then press CTRL and select the other cells or ranges.
Note: Pressing the DOWN arrow selects all cells that contain
data in that column. Using the RIGHT or LEFT arrow selects
cell ranges in smaller increments. -or3. On the File menu, click Print.
4. Under Print what, click Selection and then click OK.
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Keep the Result, Lose the Formula
You receive invoices from vendors containing formulas that calculate
billing data. Before you use the billing data, you need to convert the
formula results to plain numbers. Fortunately, in Excel it's easy to copy
and paste a result without the formula.
1.
2.
3.
4.

Select the cell containing data you want to copy.
Press CTRL+C to copy the cell data.
Press CTRL+V to paste the data in a new location.
Click the arrow next to the Paste Options smart tag, and then click
Values Only.

Create Forms for Easier Data Entry
Entering large amounts of data into an Excel spreadsheet can be very
time consuming. Using data entry forms makes your task easier. A data
entry form is a dialog box that gives you a convenient way to enter a
complete row of information at one time. To use a data entry form to edit
a list, follow these steps:1. Click a cell in the labeled row you want to add the record to.
2. On the Data menu, click Form.
3. Click OK. A data entry dialog box appears, with field labels that
correspond with the column labels in your list.

To add a new record
1.
2.
3.
4.

Click New.
Type the information for the new record.
When you finish typing data, press ENTER key to add the record.
When you finish adding records, click Close to add the new record
and close the data form.

Generate Random Numbers in Excel
Some types of analysis require you to use randomly generated numbers.
You can also use randomly generated numbers to quickly populate an
Excel spreadsheet. There's an easy function you can use to do this
automatically. Here are a few of the ways you can use it:
 Type =RAND() in a cell to generate a number between 0 and 1.
 Type =RAND()*100 to generate a number between 1 and 100.
After entering a function, you can then use the fill handle to quickly
populate as many cells as you'd like with random numbers. To use the fill
handle, click the cell, move your pointer over the lower-right corner of the
cell until it turns into a black plus sign, and drag it horizontally or
vertically across the cells you wish to populate.
Note: To change the number format of your random numbers (for
example, if you'd prefer whole numbers to decimal points), click
Cells on the Format menu. In the Format Cells dialog box, click the
Number tab and then click Number in the Category list. Then in
the Decimal places box, enter the number zero and click OK.
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Calculate the number of days between two dates
Because I write Web articles that adhere to strict publishing schedules, I
frequently need to know the number of days between two dates, such as
the number of days between a technical review deadline and a grammar
edit deadline. Here is an easy exercise you can try to display the number
of days between two dates:
1.
2.
3.
4.
5.
6.

Start Excel. A new, blank workbook appears.
In cell A1, type 1 June 2002, and press ENTER.
In cell B1, type 15 April 2001, and press ENTER.
In cell C1, type =A1-B1, and press ENTER.
Right-click cell C1, and click Format Cells.
On the Number tab, in the Category list, select General and then
click OK.

Cell C1 displays the number of days between 1 June 2002 and 15 April
2001, which is 412.

Enter Repetitive Data Quickly
If you need to type repetitive data such as some numbers or dates into a
spreadsheet, you can use the AutoFill feature in Excel to help you. Here is
an exercise you can try to practice entering repetitive data quickly.

First, fill a group of cells with names of the months:
1. Start Excel. A new, blank workbook appears.
2. In cell A1, type January and then press ENTER.
3. Click anywhere inside cell A1, and rest the mouse pointer on the
square at the lower right-hand corner of cell A1. The mouse pointer
changes into a plus symbol (+).
4. Press and hold the right (alternate) mouse button, drag the mouse
pointer to cell A12, and release the right (alternate) mouse button.
A menu appears.
5. Click Fill Months. The names of the months February, March, and
so on appear in cells A2 through A12.

Next, quickly fill in several cells with the same value:
1. In cell B1, type 1999 and press ENTER.
2. Click anywhere inside of cell B1, and rest the mouse pointer on the
square at the lower right-hand corner of cell B1. The mouse pointer
changes into a plus symbol (+).
3. Press and hold the right (alternate) mouse button, drag the mouse
pointer to cell B12, and release the right (alternate) mouse button.
A menu appears.
4. Click Copy Cells. The value 1999 appears in cells B2 though B12.

Finally, fill in several cells with a range of numbers:
1. In cell C1, type 10000.
2. Click anywhere inside of cell C1, and rest the mouse pointer on the
square at the lower right-hand corner of cell C1. The mouse pointer
changes into a plus symbol (+).
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3. Press and hold the right (alternate) mouse button, drag the mouse
pointer to cell C12, and release the right (alternate) mouse button.
A menu appears.
4. Click Series.
5. In the Step value box, type 125, and click OK. The Series dialog
box disappears, the value 10125 appears in cell C2, and the
number increases by 125 in each cell in column C up to an ending
value of 11375 in cell C12.

Import Access Tables into Excel
You've gathered the data, now you want to analyze it. Here's a quick way
to copy an Access table into Excel.
1. In the Access database window, click the table you want to export.
2. On the Standard toolbar, click Office Links.
3. Click Analyze It with Excel.
Excel automatically opens and displays your table in a worksheet.

Another way to Copy Access Data into Excel
Here's an alternative way that just requires a simple copy and paste.
1. In Access, open the table, query, or form that contains the records
you want to copy.
2. On the View menu, click Datasheet View.
3. Select the records you want to copy. Or press CTRL+A to select the
entire column.
4. Click Copy on the File menu.
5. Open an Excel workbook.
6. Click the upper-left corner of the worksheet area where you want
the first field name to appear. (To ensure that the copied records do
not replace existing records, make sure that the worksheet has no
data below or to the right of the cell you click.)
7. Click Paste on the File menu in Excel.

Import Access Data into Excel
Did you know you could import data from your Microsoft Access
databases into Microsoft Excel? Here’s a quick and easy way to do it:
1. Open the Excel workbook into which you want to import the data.
2. On the Data menu, point to Import External Data, and then click
Import Data.
3. In the Select Data Source dialog box, click New Source.
4. In the Data Connection Wizard dialog box, click ODBC DSN, and
then click Next.
5. Click MS Access Database, and then click Next.
6. In the Select Database dialog box, browse to the database file you
want to import and then click OK.
7. In the Data Connection Wizard dialog box, click the name of the
table that contains the data you want to import, then click Next.
8. Type a name and description, and click Finish.
9. In the Select Data Source dialog box, click the data source you
just created and then click Open.
TIPS & TRICKS

EXCEL 2000, 2002 XP

P a g e | 38

In the Import Data dialog box, specify where you want to put the data,
and then click OK. (While the Import Data dialog box is open, you can
click the row on your spreadsheet where you want the data to appear and
the Existing worksheet box will update automatically with the correct
information.)

Add a Calculator to the Excel Toolbar
Did you know that you could add a calculator to your Microsoft Excel
toolbar? Here's how:
1. On the View menu, click Toolbars, and then click Customize.
2. Click the Commands tab.
3. In the Categories list, click Tools, and in the Commands list, click
Custom (the one with the gray calculator graphic).
4. Drag the selected command from the Commands list to a toolbar.
(Lift your finger from the mouse when you see a plus sign next to
your pointer.)
5. Click Close. Now click the button you just added to run the
calculator.

Protect cells, worksheets, and workbooks with Password
In Microsoft Excel 2002, you can protect a single cell or a group of cells
on a worksheet from being modified. You can also protect an entire
worksheet, an entire workbook, or any combination of cells, worksheets,
and workbooks from being modified. Finally, you can restrict cell access to
specific network users.

To protect a single cell or a group of cells in a worksheet
1. With the spreadsheet open, on the Tools menu, point to
Protection and then click Allow Users to Edit Ranges.
2. Click New.
3. In the Title box, type a name for the single cell or group of cells.
4. Click the Refers to cells box, and then select the single cell or
group of cells on the worksheet.
5. In the Range password box, type a password.
Note: You can click the Permissions button in the New Range
dialog box to select users on your computer network that can have
access to the single cell or group of cells.
6. Click OK to return to the Allow Users to Edit Ranges dialog box,
and then click OK again.

To protect an entire worksheet
1. With the spreadsheet open, on the Tools menu, point to
Protection and then click Protect Sheet.
2. In the Password to unprotect sheet box, type a password.
3. In the Allow all users of this worksheet to list, select one or
more check boxes to allow users who successfully enter the
password to perform additional tasks on the worksheet, such as
select unlocked cells, insert rows, sort, and so on.
TIPS & TRICKS

EXCEL 2000, 2002 XP

P a g e | 39

4. Click OK, reenter your password, and then click OK again.
5. To test the password, close and reopen the workbook.

To protect an entire workbook
1. With the workbook open and visible, on the Tools menu, point to
Protection and then click Protect Workbook.
2. In the Password (optional) box, type a password.
Note: To protect the basic structure of the workbook, select
the Structure check box. To protect the behavior of the
workbook's window, select the Windows check box.
3. Click OK, reenter your password, and then click OK again.
4. To test the password, close and reopen the workbook.

Skip through your worksheets with a shortcut
When you are working on many programs at once, you use the keyboard
shortcut ALT+TAB to move between open programs. (If you have not
tried this, do so now — it is a great Microsoft Windows® trick.) However,
this does not work when you are moving between worksheets in the same
workbook. Do not despair; there are a couple of neat little shortcuts that
handle the job quite nicely.
To move one worksheet to the right, Press CTRL+PAGE DOWN.
To move one worksheet to the left, Press CTRL+PAGE UP.

Insert a Line Break in a Cell
In most other Office programs, to move the cursor to the next line, you
press the ENTER key. However, in Excel — the program that dances to its
own tune, and does not give a little about lines or paragraphs — you end
up in the cell below when you press ENTER. This is the cause of much
frustration. To insert a line break in a cell, follow this secret trick:


Press ALT+ENTER to start a new line while you are typing or
editing data.

Make a Style Statement with Worksheet Tabs
If you have a workbook with loads of worksheets and you are having
trouble remembering which one is which, you can customize the little tab
at the bottom of each worksheet to identify it in a special way, with a new
name or color. It is like getting to design your own nametag instead of
having to wear the standard, white.

To color one sheet
1. Right-click the tab you want to color, and then click Tab Color on
the shortcut menu.
2. Go natural.

To color all sheets in the workbook
1. Right-click any worksheet tab, and then click Select All Sheets on
the shortcut menu.
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2. Right-click the tab again, and then click Tab Color on the shortcut
menu.
3. Again, go wild.
To rename a worksheet


Right-click a tab, and then click Rename on the shortcut menu.

Move or copy a worksheet
You may know that you can just drag and drop a worksheet to a different
spot in the workbook. But for you folks who get joy from dialog boxes
(and truthfully, this one gives you more options), here you go:
To move or copy a worksheet
1. Right-click a tab, and click Move or Copy on the shortcut menu.
2. In the Move or Copy dialog box, you have options:
o
o
o

To move the worksheet to a spot within its own workbook,
select a sheet in the Before sheet box.
To move the worksheet to another open workbook, select the
workbook in the To book list and then click OK.
To keep a copy of the worksheet you are moving in this
workbook (rather than just moving it), select the Create a
copy box.

Double-click your way to fast formatting
By default, when you copy text from a different program (such as
Microsoft Word, Microsoft PowerPoint®, or even Microsoft Internet
Explorer) and paste it into an Excel cell, the original formatting comes
along for the ride. Sometimes this leaves you with a tiny little cell with
“Gigantic Formatting” that you need to fix by hand. The Paste
Options button that looks like this:
pops up, and you can use it to
keep the original formatting or to match the destination formatting (that
is, the formatting you have chosen for your cell). This is especially true if
you have a lot of cutting and pasting to do.

Paste text
formatting

from

another

program

and

keep

cell's

1. Select the text you want to pop into your Excel worksheet.
2. Press CTRL+C and switch back to Excel.
3. Double-click in the cell, and press CTRL+V.

Quick Fit Columns
Excel columns have a default column width of 8.43 characters, or 64
pixels. That means many entries are not completely visible. (If there is no
data to the right of a long entry, Excel will display the entire entry.) You
could change the column's width, but you might spend a lot of time
guessing at the appropriate width to display everything.
You can make it easy on yourself by double-clicking the right border of
a column's header cell (the gray cell at the top of the column). Doing so
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will automatically adjust the column's width to display the longest entry in
that column.

Excel Keyboard Shortcuts for Deleting Rows & Columns
Here are some keyboard shortcuts for deleting rows and columns in Excel
without having to use the menus.
Select the row(s) or column(s) you want to delete, then press Ctrl + (Ctrl key plus the minus key). The minus key can be the one on the
numeric keypad or on the top row of keys (just above the letters and
below the function keys) on standard keyboards.
To select a row or column, click on the grey box at the far left of the row
(containing the row number) or the grey box at the top of the column
(containing the column letter). Alternatively, you can select a row or
column from the keyboard. Simply move to a cell in the row or column
you want to select and press Shift + Spacebar (to select the row) or
Ctrl + Spacebar (to select the column). If you want to extend the
selection of rows or columns, be sure to release the Ctrl key, then press
and hold the Shift key and use the arrow keys (up arrow, right arrow,
etc.) to select adjacent rows or columns.
To delete the row or column you can also move to a cell in the row or
column you want to delete, press Ctrl + - and select "Entire row" or
"Entire column" from the Delete pop-up window.

Quick Double Underline
When you click the Underline button on the Formatting toolbar, Excel
underlines the data in the selected cell or range. By default, that
underline is a single line. If you need a double underline, you probably
select the Cells command from the Format menu, click the Font tab, and
then choose Double from the Underline control. However, that is a
permanent change. Excel will continue to display a double underline until
you change it back, which is probably inconvenient for most of us.
To quickly apply a double underline without changing any Excel defaults,
simply hold down the Shift key as you click the Underline button.

Start Excel Automatically when you Start your System
Would you like Excel to launch automatically when you turn on your
system? Well, more specifically, we can show you how to launch Excel
when you launch Windows. If you use Excel every day, you will be saving
yourself a little time and effort. To add Excel to your startup options, click
Start (in the Taskbar), choose Programs, right-click Microsoft Excel,
and select Copy from the context menu. Next, right-click Startup and
click Open (startup folder will open), choose Paste. Now, the next time
you turn on your PC and launch Windows, Windows will automatically
launch Excel.
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Summing Across Worksheets
To total the data for the month, select (or insert) a fifth worksheet tab
and name it Monthly Total. Since all four weeks' worth of worksheets are
arranged exactly the same, pick a cell in the Monthly Total sheet that will
contain numbers. For example, cell C2 will contain Apple sales in the
south, since it's the intersection of the Apple row and the South column.
=SUM(Week1:Week4!C2)
Now the value from cell C2 on the four worksheets (Week1 through
Week4) will be totaled and displayed in the Monthly Total sheet's cell C2.
Go ahead, enter data for Southern Apple sales in worksheets for Week1
through Week4, and then check the Monthly Total tab and you'll see that
the total now appears.

Quick Copy, Paste-Value Options
If you need, to quickly copy a formula from one cell to another, the
typical approach is to use the familiar Edit/Copy/Paste technique.
However, in some cases you may not want Excel to adjust the formula
when you copy a cell to the cell directly below it. You have two options:
Consider a quick example: cell A1 and A2 contain values. In cell A3 is the
formula =A1+A2, If you copied cell A3 to cell A4, cell A4 will end up with
the formula =A2+A3 because Excel "adjusts" formulas using relative
addressing.
Instead, move to cell A4 and press Ctrl + ' (Ctrl plus the apostrophe)
followed by Enter. Cell A4 will now contain exactly the same formula as
A3. However, if you want to quickly copy the value (not the formula) from
one cell to the cell directly below it, use Ctrl + Shift + ' (Ctrl plus Shift
plus the apostrophe).

Navigate in Excel without using Scrollbars or Arrows
1. Select any cell in the column - The cell will now have a thick line
around it to indicate it is selected.
2. Position the mouse on the bottom-centre of the rectangle where the
arrow points.
3. The cursor changes from a "black & white plus" to a "North-SouthEast-West arrow".
4. Double click the bottom-centre to move to the last cell in the
column.
5. Double click the top-centre to move to the first cell in the column.
6. Double click the left-centre to move to the first cell in the row.
7. Double click the right-centre to move to the last cell in the row.
Note: Make sure you do not move your mouse as you double
click or you may not do what you wanted. Clicking on any
edge of the rectangular selection will work.
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Navigating in Excel worksheet using Keyboard Shortcuts
To quickly swap between tabs in an Excel worksheet, use, Ctrl + PageUp
(to move to the previous worksheet tab) and Ctrl + PageDown (to move
to the next tab).
There’s a variation of this shortcut as well. Add a Shift to the combination
(that is, Shift + Ctrl + PageUp/PageDown) and Excel selects (or
deselects) a range of worksheet tabs!
To select a contiguous block or table of data in Excel, place the cursor
anywhere in the block and type Ctrl + Shift + *

Converting Numbers Stored as Text to Numbers
You can now use the Error Checking Options button to quickly convert
numbers stored as text to numbers.
1. On the Tools menu, click Options, and then click the Error
Checking tab.
2. Make sure the Enable background error checking and Number
stored as text boxes are checked.
3. Select the range of cells containing numbers stored as text,
indicated by green error indicators in the upper left corner of each
cell.
4. Click the Error Checking Options button that appears next to the
range, and then click Convert to Number.
Note: The Error Checking Options button will only appear
next to the range if the active cell in the range contains an
error, such as containing numbers stored as text. Additionally,
if the active cell contains an error, but does not contain
numbers stored as text, Convert to Number may not be an
option given when you click the Error Checking Options
button.

Rest Your Eyes with Text to Speech
Proofreading a spreadsheet can be time-consuming, blurry-eyed work,
especially when you're comparing your spreadsheet against data in
another document. But the new Text to Speech feature in Excel 2002 can
really help speed up this process by reading selected data back to you for
verification. Each cell is highlighted as the value is spoken, and when you
hear an error, you can stop to correct the error in that cell. To play back a
group of cells, follow these steps:
1. On the Tools menu, point to Speech, and then click Show Text To
Speech Toolbar.
2. Select a group of cells to read back.
3. Choose how the computer will read back your data by clicking By
Rows or By Columns on the Text To Speech toolbar.
4. Click Speak Cells if you want the computer to read back each cell
in your selection.
5. To correct an error, click Stop Speaking, and use your mouse and
keyboard to make the necessary changes.
6. Click Speak Cells to continue.
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To play back after every cell entry:
1. On the Text to Speech toolbar, click Speak On Enter.
2. Enter data in a cell. After you press ENTER, the computer will read
back the data in the cell. You can also specify a male or female
voice and the speed of playback.
Note: To use Text to Speech, your computer must have a
sound card installed and speakers attached. The available
voices depend on your default language installation and any
language packs you may have installed. Text to Speech is not
part of the standard installation of Excel, so have your
installation CDs ready.

Repeat Pictures in Excel with a Camera
How to propagate a picture to multiple worksheets based on a primary
entry. We can do it by using, Camera tool. The only way to access, the
Camera tool is by customizing the toolbar and adding it, as I don't think
it appears on any regular pull-down menu. So choose View > Toolbars
> Customize; select the Tools category; scroll down until you see the
Camera icon and text; then drag it to the toolbar.
Now add a picture (Insert>Picture>From File…) anywhere on a
worksheet, drag it where you want, and resize it. You need to get the
picture to fit inside a group of cells, leaving a slight border in one corner,
because without the border, you can't perform the next step.
Select the cells that the picture fits within (by clicking in that border and
dragging to select all the cells behind the picture). Next, click the Camera
icon. You have essentially snapped a picture of the contents of the
selected cells, and the system is awaiting your instructions to "print" it.
Move to a new worksheet (in the same workbook), click the mouse, and
the picture get "printed." You can drag the picture where you want and
even resize it.
Repeat the process for multiple worksheets, if desired. If you make any
changes in the original picture, the changes will automatically be updated
in the pictures you have "printed."
Note: You can mirror anything you want with this technique: photo,
clip art, Excel chart, calculated result(s), etc.

Change the Cell entries to Pure Text
Type a single quote ( ' ) before the entry. Excel will treat the cell as pure
text and change nothing. This technique is best for hyperlinks entries, 16digit numbers and for the entries that are automatically converted to
dates (e.g. 3/4).

How to correct cell response as 44, becomes 0.44
Go to Tools > Options/Edit and uncheck the Fixed Decimals Places
checkbox. If this command is on, you cannot correct this phenomenon
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even you use Format > Cells… > Number and set the Decimal Places
to zero.

Type an email address without appearing as hyperlink
To turn that option off in Excel 2002 and later, follow these steps:
1. Choose Tools > AutoCorrect Options…
2. Select the AutoFormat As You Type tab
3. Remove the check mark from Internet and network paths with
hyperlinks and click OK.
To undo the hyperlink creation in all versions, type the email address and
press Enter. Immediately, press Ctrl+Z, this will convert the hyperlink
back to text.

Resetting the used Cell Range
In a worksheet, if you ever end up your work in cell E50 but your scrollbar
go to row 500; it’s because, Excel may be remembering some data that
was in row 500, but has been deleted. To go to the cell, which is currently
the "Last Cell" in the worksheet, hold the Ctrl key, and press the End
key. If the Last Cell is outside the range of cells that is actually being
used, you can reset the used range, so the scroll bar works correctly.
To manually reset the used range of cells, select the last cell that contains
data in the worksheet by using Ctrl + End Key.

To delete any unused rows:




Move down one row from the last cell with data.
Hold the Ctrl and Shift keys, and press the Down Arrow key
Right-click in the selected cells, and, from the shortcut menu,
choose Delete. Select Entire Row, and click OK.

To delete any unused columns:




Move right one column from the last cell with data.
Hold the Ctrl and Shift keys, and press the Right Arrow key
Right-click in the selected cells, and, from the shortcut menu,
choose Delete. Select Entire Column, and click OK.

Lock the Title Row that keeps Visible while you Scroll
You can lock the title row (as heading) and keep it visible while you scroll
down to see the rest of your data. Assuming title row is 1, select cell A2,
then choose Window > Freeze Panes.

Column headers as Numbers instead of Letters
You can change your column headers from Alphabetical letters (default)
to Numbers. To do this, follow these steps:
1. Choose Tools > Options and select the General tab.
2. Remove the check mark from R1C1 reference style
3. Reverse this action to restore the default.
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Stop Excel to open up too many files at Startup
If you have ever experienced; Excel open up hundreds files at startup
automatically, it’s probably the reason of adding up those files in “Startup
Folder”. To set right this phenomenon, follow these steps:
Choose Tools > Options and select the General tab.
All files listed in the At startup, open all files in: box will be loaded
automatically when Excel starts. Simply, alter or remove this list.

Troubleshooting
Have ever experienced the following errors/behaviour in Excel?
1.
2.
3.
4.
5.

Excel freezes at startup and you have to repeated reboots
Excel crashes on regularly
Excel caused an invalid page fault...
Illegal Operation Error at startup
Excel crashes on opening / closing / prompts "not enough
resources".

To Do List:
1. Try opening Excel without any add-ins or hidden workbooks. If
your error disappears, there is either an “add-in” or a “hidden
workbook” which is causing problems.




On the Windows taskbar, click the Start button
Choose Run (Win Key + R)
Type "C:\Program Files\Microsoft
Office\Office\Excel.Exe"/Automation (include the quotes).

2. Try locating the XLSTART directory, move everything from there.
3. In Excel: Tools> Add-ins…, note the ones checked and uncheck
them one at the time, and restart Excel each time.
4. In Excel, Tools>Options>General. Check if a path is entered after
Alternate startup file location. Clear it.
5. Another option is to open Excel in Safe mode using Run:
"C:\Program Files\Microsoft Office\Office\Excel.exe" /Safe
6. Also, you might try using Run:
"C:\Program Files\Microsoft Office\Office\Excel.exe" /Regserver
7. Another possible problem is a corruption of toolbar customization file:




Locate all files with extension .xlb
Rename the extension(s) to something like .old
Now try to start Excel again.

Paste a selecting range as Picture or Picture Link
1. Select the range
2. Edit | Copy in the menu bar (or Ctrl-C)
3. Go to the new worksheet and with the Shift key pressed click on
Edit | Paste Picture Link.
4. Go back and do the same for the other areas.
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If you change the original range, the picture will change too (values and
formatting!). You can use this sheet always to print because it will always
update if you change the original data.
Note: You see that the edit menu will change when you press the
shift button while you click on Edit.

Change Formulas to Values
You can do this to convert all formula cells on a worksheet to values:
1. First select all cells on the sheet with the shortcut Ctrl+A or click on
the space above the first row header and on the left of the first
column header.
2. Click Edit > Copy (or right click the selection and choose Copy)
3. Click Edit > Paste Special (or right click the selection and choose
Paste Special)
4. Check "Values"
5. Click OK to complete the process
6. Press Esc key to clear the clipboard
7. Press Home key to go to cell A1
Note: This function is irreversible, so think beforehand. By applying
this feature, all your formulas will be permanently converted to
simple values.
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20 GREAT EXCEL TIPS
How to get the most from Excel:
Warning:
First, some of these functions work only when the Analysis ToolPak add-in
is enabled. To do this, choose Tools | Add-ins, select the check box titled
Analysis ToolPak, and click on OK. If Analysis ToolPak is not installed,
you'll be prompted to install it.

COUNTIF Function
The COUNTIF function counts the number of times a condition is met. For
example, if you have a list of days in a month in column A (cells A1:A31)
and your sales receipts for those days in column B, you can count the
number of days that your sales exceeded $5,000 with this function:
=COUNTIF(B1:B31,">5000"). A similar function, SUMIF, totals values
instead of counting them.

CHOOSE Function
The CHOOSE function takes a number from 1 to 29 and a list of items (up
to 29) and returns the item that corresponds to the number. One use for
this function is to return the day of the week for a given date. To do this,
couple it with the WEEKDAY function, which gives a day number (1 to 7)
for a date, then use CHOOSE to turn the number into a day name.
Assuming your date is in cell B2, use this function to get the day of the
week it falls on: =CHOOSE(WEEKDAY(B2), "Sun", "Mon", "Tue", "Wed",
"Thu", "Fri", "Sat")

MOD Function
MOD (or modulus) returns the remainder when one number is divided by
another. For example, =MOD(4,3) returns 1. Use this function to format
every other row of a worksheet by selecting the cells to format and
choosing Format | Conditional Formatting. Choose Formula Is and type
this formula: =MOD(ROW(),2). (ROW returns the current row number.)
Click on Format and set a pattern for alternate rows on the Patterns tab.
Click on OK when you're done.

DATEDIF Function
The DATEDIF function, undocumented in most
Excel versions, returns the time between two
dates, measured in your choice of completed
years, completed months, or days. This function is
handy for calculating a person's age. Put the
person's birth date in cell A1 and write this formula
in cell B1 to calculate the age in years: =DATEDIF(A1,NOW(),"y")
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NETWORKDAYS Function
The NETWORKDAYS function calculates the
number of workdays (excluding weekends)
between two dates. You can specify holidays that
should be excluded from the count. Place your
holiday dates in column A, then select them and
click on Insert | Name | Define and name the
range holidays. Place the start and end dates in cells B1 and C1 and use
this function to calculate the number of workdays between the two:
=NETWORKDAYS(B1,C1,holidays)

CONVERT Function
Use the CONVERT function to convert measurements from one unit to
another. For example, to convert a value in cell A2 from inches to
centimeters, use this function: =CONVERT(A2,"in","cm"). Excel Help
contains a complete list of the conversions and function arguments to use
for each.

ISERROR Function
The ISERROR function returns True when the cell to which it refers
contains an error and False when it doesn't. Combine this with NOT and
an IF function to create a string that adds a range of numbers, ignoring
any cells that contain errors. So, if your numbers appear in the range
A2:A6, type this function and press Ctrl-Shift-Enter to enter it into the
cell, as it is an array function (a function that performs multiple
calculations
on
multiple
values):
=SUM(IF(NOT(ISERROR(A2:A6)),A2:A6,""))

LARGE Function
The LARGE function will return the nth largest number in a list. If you
have a list of test scores in cells A2:A10, you can find the third-best score
with this function: =LARGE(A2:A10,3). There is a similar function, SMALL,
which finds the nth smallest number in the list.

SUBTOTAL Function
SUBTOTAL calculates a subtotal for a list, which may be useful when you
are using a filtered list. The problem with using SUM with a filter is that
the function totals both hidden and visible values. SUBTOTAL, however,
sums only the visible values. Instead of writing the SUBTOTAL function
yourself, click on the AUTOSUM button on the toolbar and it will write the
correct SUBTOTAL function.

SQRT Function
To calculate the square root of a number, Excel uses the SQRT function;
for example, =SQRT(25) calculates the square root of 25. When you
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need, say, a cube root, you must work with the mathematical idea that
the cube root is calculated by raising the number to the power of 1/3. So
calculate the cube root of 27 using =27^(1/3). This principle extends to
let you find the root of any number by raising it to a fractional power.

Look-Up Functions
Look-up functions find data in tables. If you have a list of office names in
column A and sales figures in columns B and C, the function
=VLOOKUP("Seattle",A2:C15,2, FALSE) looks for Seattle in column A of
the data table (A2:C15) and returns the corresponding value from column
B (the second column in the table). Use FALSE in the formula to tell Excel
that the data is not sorted and that an exact match is required.

TODAY() Function
The function =TODAY() places the current date in a cell. You can use this
with a macro to save a file using today's date as its filename. This sample
macro code saves the file using the contents of cell A1 as the filename.
Simply place =Today() in cell A1 and run the following macro to test it:
Sub savenamefromcell()
Dim savename AsString
savename=Sheets(1).Range("A1").Value & ".xls"
ActiveWorkbook.SaveAs Filname: =savename
End Sub

FREQUENCY Function
Use the FREQUENCY function to count the instances a particular number
occurs in a series of values. The function requires a set of ranges (or bins)
to group the values. For example, use bins of 5, 10, 15, and 20 to report
the frequency of values in the ranges 0:5, 6:10, 11:15, and 16:20.
Because FREQUENCY is an array function, you must first select a range of
cells the same size as the bin range, then type the function =FREQUENCY
(A1:D15, F2:F5) then press Ctrl-Shift-Enter. This example uses bins in
the range F2:F5 to count numbers in the range A1:D15.

OFFSET Function
Creating dynamic ranges is easy with the OFFSET
function. For example, this function, used in the
Insert | Name dialog, names a list of numbers in
column A, assuming the list begins in cell A1 and
there are no blank cells in the range:
=OFFSET($A$1,0,0,COUNTA($A:$A),1).
If
you
name your range, for example, FilledCells, the function =SUM(FilledCells)
will sum the values in the list. The results update automatically as
numbers are added or removed. The arguments for the OFFSET function
are the starting or reference cell; the number of rows and columns up,
down, or across from the reference cell; and the number of rows and
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columns to return. The OFFSET function is quite useful for creating charts
that update as new data is added.

FV Function
The future value function, FV, calculates the return
on a given investment. To calculate the ten-year
value of $1,000 invested today at 5 percent
interest (compounded monthly), =FV(5%/12,
10*12,,-1000) returns $1,647.01. If you make
additional monthly payments of $10 per month,
the future value is =FV(5%/12,10*12,-10,-1000) and returns $3,199.83.
Negative values are used because you are paying out money, and you
should take care to scale the interest rate to match the periods used.
We're assuming 12 periods per year, so the interest rate is 5%/12.
Little-known functions like these open new avenues of productivity and
fun for Excel users.

IF Function
Online Extra
Much to our surprise, many readers aren't familiar with one of Excel's
most useful functions—IF—which evaluates a condition and returns one
value when the condition is true and another when the condition is false.
For example, consider a situation in which you charge $15 for regular
shipping and an extra $10 for expedited shipping. If cell A2 of your
invoice contains a Y for expedited shipping, you can calculate the total
shipping using this function: =IF(A2="Y",25,15)

OR and AND Functions
Online Extra
The functions OR and AND evaluate tests and return either True or False.
OR returns True when any of its tests is true and False when they are all
false. AND returns True only if all tests are true and returns False if one or
more is not true. So =OR(2=3,4=4) returns True and =AND(2=3,4=4)
returns False. These functions are often used in combination with
functions like IF to configure multiple tests.

INT Function
Online Extra
The INT function rounds a number down to the nearest integer. It is
useful for extracting the various parts of a real number. Use =INT(A1) to
return the integer portion of the number in cell A1 and =A1-INT(A1) to
return the decimal fraction portion (the part after the decimal point). One
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common use for INT is with the RAND function, extracting the integer
portion of a random number, like =INT(RAND()*25).

PROPER Function
Online Extra
Use the PROPER function to adjust the capitalization of a cell entry.
=PROPER(A1) displays the contents of cell A1 in proper case where only
the first letter of each word is capitalized. The functions UPPER and
LOWER are similar and display text in all uppercase or all lowercase,
respectively.

OMONTH Function
Online Extra
The EOMONTH function calculates the last day of the month and can be
handy when determining the day on which a payment is due. The function
takes a date and a number of months ahead. Use 0 for the current
month, 1 for next month, -1 for last month, and so on. For example,
=EOMONTH(Today(),1) calculates the last day of next month.
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